HentHighSchool Development Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

collapse
* Recent Posts
Re: Test version for 0.2 by Avox
[Today at 04:15:40 pm]


Re: [HHS+ 1.10 Beta] Public Beta Discussion / Feedback by squark
[Today at 02:04:55 pm]


Re: Test version for 0.2 by Avox
[Today at 02:01:34 pm]


Re: [HHS+ 1.10 Beta] Public Beta Bugs by dzekas_darbis
[Today at 09:14:21 am]


Re: [HHS+ 1.10 Beta] Public Beta Bugs by joaomatos93
[Today at 08:58:16 am]


Pages: 1 [2]   Go Down

Author Topic: Help with Maid Club and with Jessica Underwood corruption  (Read 7239 times)

Dragonblood

  • Moderator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1542
  • Code monkey
    • View Profile
Re: Help with Maid Club and with Jessica Underwood corruption
« Reply #15 on: July 04, 2021, 02:26:24 am »

1) I realized that the Underwood hacking stuff only takes place in the computer lab, not at the home computer (this has been fixed in the internal version, where it can be done in either location).

2) The event flags do not appear to be correctly set within the save file. The variable in question is located in Events\ExtensionLibrary\DetectiveEvents\JessicaUnderwoodDetective.ve.xml, and in the save, only Pos0 is set to true, when Pos1 should also be set to true. Toggling that in the debugger makes the event proceed as normal.
Logged

Strabozio

  • Newbie
  • *
  • Offline Offline
  • Posts: 11
    • View Profile
Re: Help with Maid Club and with Jessica Underwood corruption
« Reply #16 on: July 04, 2021, 11:31:49 am »

Thank you very much for your help

I imagine that i was doing something wrong when debugging, because even though that file was before my attempt at debugging i always get a greyed out option to save so i thought that changing values "live" was enough to make them change
Is there something i am missing altogether on how to debug?
Logged

Dragonblood

  • Moderator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1542
  • Code monkey
    • View Profile
Re: Help with Maid Club and with Jessica Underwood corruption
« Reply #17 on: July 04, 2021, 02:00:39 pm »

so i thought that changing values "live" was enough to make them change

That should be correct. To be honest, the only real issue I saw was with the event flags variable having the one missing checkmark, so I'm inclined to think you just misclicked or something when editing it.
Logged

Strabozio

  • Newbie
  • *
  • Offline Offline
  • Posts: 11
    • View Profile
Re: Help with Maid Club and with Jessica Underwood corruption
« Reply #18 on: July 04, 2021, 02:05:56 pm »

Then i still don't quite understand, because if i have been debugging the right way (even though this save was before the actual debug was done) the event should have been scheduled and started
Honestly i'm perfectly happy that you fixed my save file, but also curious on why my debugger didn't debug
Logged

most.lag-5678

  • Newbie
  • *
  • Offline Offline
  • Posts: 1
    • View Profile
Re: Help with Maid Club and with Jessica Underwood corruption
« Reply #19 on: July 04, 2021, 08:12:56 pm »

which one that needed to get check ? i just got into the game and doesnt understand about debuging and stuff
Logged

Dragonblood

  • Moderator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1542
  • Code monkey
    • View Profile
Re: Help with Maid Club and with Jessica Underwood corruption
« Reply #20 on: July 04, 2021, 09:34:17 pm »

Then i still don't quite understand, because if i have been debugging the right way (even though this save was before the actual debug was done) the event should have been scheduled and started
Honestly i'm perfectly happy that you fixed my save file, but also curious on why my debugger didn't debug

The event was scheduled correctly, it just couldn't trigger due to this problem:
Quote
The variable in question is located in Events\ExtensionLibrary\DetectiveEvents\JessicaUnderwoodDetective.ve.xml, and in the save, only Pos0 is set to true, when Pos1 should also be set to true.

I'm not sure how exactly it happened, but it was probably from when you were trying to reset the state of the event chain.
Logged
Pages: 1 [2]   Go Up
 


SimplePortal 2.3.3 © 2008-2010, SimplePortal