HentHighSchool Development Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

collapse
* Recent Posts
Re: Girl packs by Aren117
[Today at 06:39:30 pm]


Re: Girl packs by Leortha
[Today at 06:37:28 pm]


Re: Girl packs by Aren117
[Today at 05:59:44 pm]


Re: Girl packs by Leortha
[Today at 05:02:29 pm]


Re: Tagging Tool 2.8 + TagSet Extended by Goldo
[Today at 03:23:52 pm]


Pages: 1 [2]   Go Down

Author Topic: Aaror's compiled finished mods  (Read 35826 times)

LewdVoid42

  • Full Member
  • ***
  • Offline Offline
  • Posts: 116
  • Tentacle monsters are from the void :)
    • View Profile
Re: Aaror's compiled finished mods
« Reply #15 on: February 17, 2020, 08:52:38 pm »

Hi ! Subject of reply: Hypno-Strip Mod

I'm replying in this thread, because I think/believe(though not 100% sure), the Exception I've been getting lately, is due to this Mod, since I always get it when I successfully Hypnotize a subject, though a choice to "Strip the subject" does not appear.

The Exception is : Unable to find Remote Event 'FunctionLibrary\Suggestion\Behavior\EnhanceEducation' .

I looked to that location in the games files, and found no "EnhancedEducation" event there, nor have I found that one was supplied by the creator of the mod.

Perhaps it is caused something else ? Anyone familiar with this "Exception" as to, if it is caused by another mod, or the Base game itself ?

PS - I'm using version 1.9.5, and a new game was started after installing any mods .

Thanks for any Help, and / or Replies to Identify and 'fix'   :)


Hey if you are still looking for a fix to the "EnhanceEducation" problem I may have a quick and dirty solution to it.
First to clarify I am in no way educated in programing, but so far the fix has worked without problems.
So you have to open HHS+ and go into the developer tab.
Then enter the visual event editor.
From there, create a new event and leave it completely blank.
Save it with the name "EnhanceEducation" inside:
\Schools\NormalSchool\Events\FunctionLibrary\Suggestion\Behavior

And boom you are good to go, the mod should work without problems. If anyone actually knowleadgeable in programing can comment if this would create any problems in the game, I would appreciate it. I figured if the command wasn't being used in this version of the game anyways, making a dummy for it shouldn't cause any problem.
Enhance Education was one of the hypnosis options in the earlier versions of the game (when I made the mod).  Because I had to "link" my mod I had to change the parent VEE, which means my mod is using the old parent that includes the link to the EnhancedEducation VEE.  I will try to re-do the mod tonight or tomorrow...

Edit, I'd have to learn the new way hypno works to do this, and I don't have the time/energy right now, sorry.

This may be deadposting, but for anyone who is still using the Hypnostrip mod for 1.9.5, I actually went in using devtools and slightly modified the ChangeBehaviorMain and removed the search for EnhanceEducaton so you don't get the error. Just put my version where the other one is supposed to go
(Schoolname>Events>FunctionLibrary>Suggestion>Behavior)

If you have any issues (in 1.9.5) and you are using the rest of the mod files just reply i guess and Ill see if I can help
« Last Edit: February 17, 2020, 08:55:37 pm by LewdVoid42, Reason: Forgot to attach the modified file, rip »
Logged

Kilted_Master

  • Full Member
  • ***
  • Offline Offline
  • Posts: 178
    • View Profile
Re: Aaror's compiled finished mods
« Reply #16 on: December 20, 2020, 09:13:49 pm »

Hi ! Subject of reply: Hypno-Strip Mod

I'm replying in this thread, because I think/believe(though not 100% sure), the Exception I've been getting lately, is due to this Mod, since I always get it when I successfully Hypnotize a subject, though a choice to "Strip the subject" does not appear.

The Exception is : Unable to find Remote Event 'FunctionLibrary\Suggestion\Behavior\EnhanceEducation' .

I looked to that location in the games files, and found no "EnhancedEducation" event there, nor have I found that one was supplied by the creator of the mod.

Perhaps it is caused something else ? Anyone familiar with this "Exception" as to, if it is caused by another mod, or the Base game itself ?

PS - I'm using version 1.9.5, and a new game was started after installing any mods .

Thanks for any Help, and / or Replies to Identify and 'fix'   :)


Hey if you are still looking for a fix to the "EnhanceEducation" problem I may have a quick and dirty solution to it.
First to clarify I am in no way educated in programing, but so far the fix has worked without problems.
So you have to open HHS+ and go into the developer tab.
Then enter the visual event editor.
From there, create a new event and leave it completely blank.
Save it with the name "EnhanceEducation" inside:
\Schools\NormalSchool\Events\FunctionLibrary\Suggestion\Behavior

And boom you are good to go, the mod should work without problems. If anyone actually knowleadgeable in programing can comment if this would create any problems in the game, I would appreciate it. I figured if the command wasn't being used in this version of the game anyways, making a dummy for it shouldn't cause any problem.
Enhance Education was one of the hypnosis options in the earlier versions of the game (when I made the mod).  Because I had to "link" my mod I had to change the parent VEE, which means my mod is using the old parent that includes the link to the EnhancedEducation VEE.  I will try to re-do the mod tonight or tomorrow...

Edit, I'd have to learn the new way hypno works to do this, and I don't have the time/energy right now, sorry.

This may be deadposting, but for anyone who is still using the Hypnostrip mod for 1.9.5, I actually went in using devtools and slightly modified the ChangeBehaviorMain and removed the search for EnhanceEducaton so you don't get the error. Just put my version where the other one is supposed to go
(Schoolname>Events>FunctionLibrary>Suggestion>Behavior)

If you have any issues (in 1.9.5) and you are using the rest of the mod files just reply i guess and Ill see if I can help

Like your post, some may consider the 'same' about this post ?

But, anyway, at the least, I wanted you to know, that your effort is appreciated  ;).

I just got the 'bug'/desire, to try this game again, and was going through all the Mods in this section, and came across this, your reply to the problem.
 
I'll be trying this out in a 'near-future' play-through, and will comment any results I find.

Again, I just wanted to say ; " THANK YOU" !  ;D

PS to "aaror" ;
Just off-the-cuff, Do you know if this Mod, will work in HHS+, with Lexville Mod installed ?

Well, at any rate, that's what I'll be trying it out in, so I guess we'll see  . . . .  ::)  8) .
Logged

aaror

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 468
    • View Profile
Re: Aaror's compiled finished mods
« Reply #17 on: January 24, 2021, 08:11:20 pm »


Like your post, some may consider the 'same' about this post ?

But, anyway, at the least, I wanted you to know, that your effort is appreciated  ;).

I just got the 'bug'/desire, to try this game again, and was going through all the Mods in this section, and came across this, your reply to the problem.
 
I'll be trying this out in a 'near-future' play-through, and will comment any results I find.

Again, I just wanted to say ; " THANK YOU" !  ;D

PS to "aaror" ;
Just off-the-cuff, Do you know if this Mod, will work in HHS+, with Lexville Mod installed ?

Well, at any rate, that's what I'll be trying it out in, so I guess we'll see  . . . .  ::)  8) .

The only files the mod touched were related to hypnotism, so if Lexville changes the hypnosis files it would probably break my mod (or vice versa) but if Lexville doesn't touch the hypnosis files then a fixed version of my strip mod would work. 
Logged
Pages: 1 [2]   Go Up
 


anything
SimplePortal 2.3.3 © 2008-2010, SimplePortal